Cutadapt loading wrong version

Hi,

I am finding it hard to understand why when loading the cutadapt it loads an older version.

I have put the relevant error stating something about a “VARIANT” here: https://gist.github.com/anonymous/0074fe513d72b8817d1649d1d27998d3. I create the job scripts via perl and then submit them. The errors one see’s are result of using this method. If I submit the shell scripts directly in the command line, they run just fine.

The only way I can ensure I have the correct version of cutadapt running is if I preload it into the terminal before I run the perl script to create the shell.

Please advise.

Best wishes,

Jonathan Armstrong

Hi Jonathan,

The VARIANT message occurs when a different version of an application has already been loaded. Before loading the apps/cutadapt module, try purging all your current modules using the module purge command. This should ensure the correct version is loaded.

Thanks,

Mark.