How can I launch in my own VPC?

Thanks for the solution now everything is working as expected with default cloud formation template.

Now I want to launch the alces flight cluster in my own VPC. I have referred the white paper for this
This document provides the different cloud formation template than the default one. How can I install the additional features with this cloud formation template?
Also no option to disable autoscalling as well.
Waiting for your reply.

Hi @chandrakantlotke,

That white paper is targeted at the 2016.2 release – we would recommend using a more recent version of Flight Compute so you have access to all the latest features.

You shouldn’t need to use your own VPC with Flight Compute Solo on AWS Marketplace as the networking is automatically configured to correctly support the cluster. Having said that, you’re welcome to adapt the CloudFormation template as you see fit.

We’d be interested to hear what enhancements your adaptations provide so we can look at including them in a future release. Let us know how you get on!

Thanks for the reply.

Actually, I have a requirement to launch the alces cluster in custom VPC and in private subnet only(with NAT gateway attached ).

Can you please provide me the latest cloud formation template for custom VPC?

Also, I would like to install some additional features like pbspro on login and compute nodes. The features are listed here

One last point, I am able to launch the cluster with the template provided in the above white paper but when I run the “nodeattr -n nodes” it shows nothing. Please note that I have loaded the services/pdsh.

You can download the latest CloudFormation template from the Alces Flight Solo page on AWS marketplace.

Once you’ve got the template, you can add new CloudFormation resources to add a NAT gateway and update the VPC route resources to change how the VPC works to suit your requirements. Once you’ve created your modified CloudFormation template, use the CloudFormation console to create the stack as usual.

You’re probably not seeing any output from nodeattr -n nodes as the command won’t show any results until compute nodes have started up.

Let us know how you get on – it’d be great to see the enhanced template you create and hear what you’re using Flight Compute for!

Thanks for the reply.
I am able to launch a cluster with the latest template.
I just wanted to know that how to start the compute nodes, so that -n nodes gives me an output?

Great, glad to hear you’ve got the latest template working!

Once the compute nodes have started up they’ll be automatically added to the genders file and appear in the output from nodeattr -n nodes. It may take a few minutes for the first node to start, depending on what options you specify to the template. If you’re using autoscaling, submitting new jobs to the job scheduler queue will automatically start up the number of nodes required to service the submitted job.