Qiime 1.9.1 Installation Issue

Hi all,

I have been trying to install Qiime version 1.9.1 from the volatile repository and keep getting errors. This is the latest error I received. I tried manually adding the package.cache file, but ran into an error with byte space.

Does anyone know how to work-around this issue and successfully install Qiime 1.9.1?

Any help is appreciated.

Quick update: I tried downloading all of the versions of Qiime available in the volatile repository. When I tried to install version 1.9.0, I got the same error as above. However, when I tried downloading versions 1.7.0 and 1.8.0 I got an error saying: “Unable to download source”.

Any additional insight is appreciated.

Hi Courtney,

Manually adding the package.conf file should do the trick:

module load apps/ghc
ghc-pkg recache

What byte-space error are you running into?

The download links have changed for the older 1.7.0 an 1.8.0 versions of QIIME since the packages were created so we’ve made a change in the volatile repo to reflect the updated links. If you update your volatile repo, alces gridware update volatile, and try again the source should be located this time around.

This command worked and allowed me to install version 1.9.1. Thank you very much for your help!

Hi Mark,

I tried updated the volatile repository with your command and am still getting the same “Unable to download source” error.

Courtney

Glad to hear you’ve got QIIME 1.9.1 installed successfully.

Regarding 1.7.0 and 1.8.0: can you check you’ve got the right version in the output from the update command please?

It should look something like this:

[alces@login1(mycluster) ~]$ al gr up volatile
Updating repository: volatile
          Update ... OK (At: f0df265)

The f0df265 is the important bit – it should match the latest commit of the volatile repo GitHub project.

Note that alces gridware update will, by default, update the main repo rather than the volatile repo. You’ll need to explicitly specify alces gridware update volatile to ensure the correct repo is being updated.

Hi Mark,

I ran the command you suggested and got the same output as you. Here is a screenshot of the error I am receiving.

.

Ok, thanks for the information – looks like the checksum for the package has also changed. We’ll take a look and get back to you with a fix.

Thank you so much Mark. I really appreciate your help!

Can you do a further alces gridware update volatile and try again please? It turns out the checksum for the 1.7.0 tarball remains the same for the new download location, but the 1.8.0 tarball has changed for some reason! :slight_smile:

Hi Mark,

That worked and I was able to install both 1.8.0 and 1.7.0! I also got a new version in the output of the update command; it was 4dfa1bc.

Thanks for your very quick responses and help.

Have a good rest of your day!